Back to overview
Degraded

Operations are failing

Nov 20 at 06:19am PST
Affected services
Website
Corporate Admin Portal
Backend API
End User Portal

Resolved
Nov 20 at 07:58am PST

We have identified the source of the issue and resolved it.

Created
Nov 20 at 06:19am PST

Registration, login, search, and donate are failing for some users. We are investigating and will provide an update when we know more.